Back to overview
Resolved

Emergency Maintenance

Jul 28, 2026 at 6:04pm UTC
Affected services
Network Connectivity: PHX01
vCloud Director: PHX01
Data Protection: PHX01

Resolved
Jul 31, 2026 at 4:41pm UTC

Per our previous update, performance degradation experienced within the Orion DaaS environment has been resolved, and services are operating at expected performance levels.

Our engineering team will continue to closely monitor the environment, coordinate with the data center operator, and take additional continuity precautions until full facility power redundancy has been restored.

If you experience any issues with your Stellar Cloud services, please contact our Support team immediately at 888-434-1043 so we can assist you promptly.

Updated
Jul 30, 2026 at 2:32pm UTC

Stellar’s engineering team has completed the remediation necessary to restore the affected services. At this time, the performance degradation experienced within the Orion DaaS environment has been resolved, and services are operating at expected performance levels.

While customer-facing service has been restored, the underlying facility incident remains ongoing. Our data center partner continues to repair the affected power infrastructure, and the facility remains in a degraded power state. As a result, Stellar is currently operating on a single facility power path while full power redundancy is restored.

Although we are not currently observing any customer-facing service impact, our engineering team will continue to closely monitor the environment, coordinate with the data center operator, and take additional continuity precautions until full facility power redundancy has been restored.

If you experience any issues with your Stellar Cloud services, please contact our Support team immediately at 888-434-1043 so we can assist you promptly.

We sincerely apologize for the disruption this incident caused and appreciate your patience as our teams worked around the clock to stabilize and restore the affected services.

We will provide a formal Reason for Outage (RFO) tomorrow outlining the root cause, the actions taken, and the preventative measures resulting from this incident.

Thank you for your continued trust in Stellar.

Updated
Jul 29, 2026 at 3:56pm UTC

We are still currently working through an infrastructure issue affecting some of Stellar's Orion cloud services. Our engineers are on site adding in capacity to help address the added strain on our services due to the ongoing power issue at the datacenter. We had expected the power issue to be resolved over night, however the datacenter is still awaiting affected power restoration parts to arrive before that is resolved. We are attempting to work around this reduced power output to bring customers services operations back to normal.

We will provides updates as we have them on this status page.

Upon this incident being fully resolved, we will then share an RFO (Reason for Outage) outlining the root cause, the actions taken and any preventative measures implemented.

We sincerely apologize for the disruption and appreciate your continued patience as we work to resolve this ongoing issue.

Updated
Jul 28, 2026 at 8:15pm UTC

We are still responding to an infrastructure issue affecting some Stellar Cloud services. Our engineering team is actively working with our data center partner to restore full service as quickly as possible.

We will continue to provide updates here on our status page.

Once the incident has been fully resolved and our investigation is complete, we will share a Reason for Outage (RFO) outlining the root cause, the actions taken, and any preventative measures.

We sincerely apologize for the disruption and appreciate your patience while we work to resolve this issue.

Created
Jul 28, 2026 at 6:04pm UTC

Today at approximately 9:40 AM MST, our Phoenix data center partner, EdgeConneX, reported a roof leak that damaged their power infrastructure, requiring emergency maintenance. As part of the repair process, one side of the redundant power feeding Stellar's environment has been temporarily de-energized.

We are currently seeing intermittent disruptions for some DaaS users, including login issues and session timeouts. To help minimize customer impact, we have proactively disabled select cluster features to reduce workload movement and prevent additional session disconnects.

A Stellar engineer is on-site at the data center working alongside the EdgeConneX team. At this time, the estimated time for full restoration of redundant power is end of day. We will provide updates as new information becomes available.

We sincerely apologize for any inconvenience and appreciate your patience as we work with our data center partner to restore full redundancy.