Back to overview
Degraded

Orion Cloud Service Update: Impact from Upstream Carrier

Apr 25 at 11:22pm UTC
Affected services
Network Connectivity: PHX01

Resolved
Apr 27 at 12:11am UTC

The temporary routing adjustments we implemented to mitigate the impact have now been safely rolled back, and all services are operating through their normal paths. Performance has returned to expected levels across all regions.

Summary:
• The issue originated from an upstream carrier and was outside of Stellar Technologies’ direct infrastructure.
• Temporary routing changes were put in place to minimize disruption.
• Normal routing has been fully restored, and all systems are now stable.
• No data loss or security incidents occurred during this event.

Next Steps:
• We will continue to monitor all systems closely to ensure stability.
• A full post-incident review will be conducted with the upstream carrier to prevent similar occurrences in the future.

Thank you again for your patience and trust during this incident. If you experience any further issues, please don’t hesitate to reach out to our support team at 888-434-1043 option 2 or support@stellar.tech.

Created
Apr 25 at 11:22pm UTC

We want to inform our valued customers that our Orion Cloud services are currently being impacted by an issue with one of our upstream network carriers.

Our engineering teams identified degraded performance beginning earlier today and have traced the disruption to an external carrier responsible for a segment of our service connectivity. We are actively working with their technical teams to resolve the situation as quickly as possible.

Current Status:
• Orion Cloud remains operational, but customers may experience intermittent network latency, slower response times, or minor service interruptions depending on their location and service region.
• There is no data loss or security risk associated with this event.

Our Response:
• We have rerouted traffic where possible to minimize the impact.
• Our teams are closely monitoring the situation and are in constant communication with the upstream provider for updates and resolution timelines.
• We will continue to provide updates at regular intervals and immediately inform you when service has fully normalized.

We understand how critical Orion Cloud is to your operations and appreciate your patience and trust as we work to restore full service levels.

If you are experiencing persistent issues, please reach out to our support team at 888-434-1043 option 2, or support@stellar.tech.